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1. Introduction.

Welcome to Power Data! Power Data is an easy-to-use and high performance database management
system (DBMS) for the Nokia Communicator. Power Data allows you to capture, store and retrieve
information about similar items.

Power Data offers you a wide range of powerful tools for managing databases like finding, sorting, and
filtering records. It allows you to have multiple tables in a single database. Power Data supports import
from and export to CSV and dBase (DBF) files.

You can download the latest version of Power Data from http://www.epocware.com.

2. Key concepts.

2.1. Database.

A Database is a file that contains structured information that's related to a particular subject or purpose,
such as tracking customer orders or maintaining a music collection. It may contain one or more Tables.

: WI
& File storage LOMmMUNICALET: Open
=1 Communicator | | 5P MyData 30/11/01 |
documents Move
Memory Card
Delete
x
ﬂ Close
AWy Dats Open
tahle
EfzTables ‘New
== Orders | table
E= Customers Delete
|| E5Products tahle
_ S Tasks Close
1] database
2.2, Tables.

A Table is a collection of data about a specific topic, such as products or orders. Tables organize data into
columns (called Fields) and rows (called Records).
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yaiatasivic ULIEI'I
ID FirstName LastName EmailAddress r_e;urd
: - - e
0 John Smith john{@smith.com record
1 Bob Jones bob@jones.co.uk
2 Bond 007@vah Delete
¥ ames on yahoo.com record
o Close
|| | table

2.3 Records and Fields.

A Record is a collection of data arranged in one or more Fields. Each record describes some unique “real
word” entity such as person, product or order.

- | iMyiDatasiiailinglist 3
l IHEW e COTH
0 -
_1 FirstName » Jobn
ﬂ 5 LastName m» Smith ; Cancel
EmailAddress| » john@smith.com|
k o

Each Field represents some aspect or attribute of the entity such as name, address, or date of birth of a
person. The definition of a field includes the name of the field and the type of data to be recorded.

Power Data supports wide range of field types, including text strings, numbers (integers), yes/no
(Boolean), floating point (currency) and date fields.

3. Tutorial.

The best way to learn a program is to create something in it. This chapter will take you through the
process of making a database to store a mailing list data.

3.1. Creating a database.

To create a new database, select the New database command form the File menu. The New database
dialog will appear, where you can choose the name and the folder for the database file.

© Copyright 2002-2005 Epocware, Paragon GmbH 5
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&

=

P

Power Data

3:34 i1

X

el -

P15y

=7 Communicator
5} My Data

Browse

Cancel

Then you will be asked if you want to password protect the new database.

&

=

P

Power Data

3:40 i1

X

EOWETdIAla

? Question

f)o you want to set password?

Yes

No

If you choose to set the password, then you will be prompted to enter it.

ke

=

P

Power Data

346

X

EDWETdIala

Cancel

Note 1: You will be able to change the password later by selecting the Change password command from

the File > More menu.

Note 2: If you choose not to set a password, then you won’t be able to set it later.

Now the database is created. There are no tables in it. The next step is adding a table.
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EAyDate Open

- tahle
ER LU
EfzTables | Ne

tahle

Delete

ﬂ table
j Close
Il datahase

3.2. Adding tables to a database.

To add a new table to a database, press the New table button. Enter the name for the new table:

- | WMyiData OK
EfTables

Once you entered the name, the Templates dialog will appear, where you can choose a template for the
new table. If you don’t want to use the templates, select the Other (blank) item.

- | gidyibata T P S— oK
Tiz'e_f_ | Other (blank 0
EEEE e Accounts I
J Addresses
ﬁ Assets
ﬂ Authors Cancel

We choose the Mailing List template for our tutorial. Then the process of defining the fields within the
table begins.
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(= X

MailingListID Number (integer)
Prefix Text {20)
FirstName Text (50)
MiddleName Text (30)
LastName Text {(50)

I

Add
field
- Remove
field

Change
field

OK

In the Table fields dialog you can see a list of predefined fields with their types. To remove a field, select
it in the list and press the Remove field button. To add a new field, press the Add field button. In the
appeared Add field dialog enter a name for the new field and select the field type.

L -
& oK
aaodiels Text | —
Name » | Number (integer)
Type| » | Floating point (money)
ﬂ Size » | Yes/No
P | Date
i K Memo — Sl
3.2.1. Field types.
Type name Description Examples of use
Text Text string. You can set the Size of | Name, Address, Email, Note.
text field up to 255 characters.
Number (integer) Integer number. Count, ID, Quantity.
(You can set the Primary key
option to Yes, if you want to get a
unique auto incremented field.)
Floating point Floating-point number. Price, Expenses.
Yes/No Boolean field. You can only store | Yes/No values.
Yes or No in this field.
Date Date. Date.
Memo Text string of unlimited length. Note, Memo, Address.
Embedded file Embedded document or image file. | Maps, Documents, Photos.

We need the following fields for our simple Mailing List database:
1. ID (unique Id of each record).

2
3.
4. Email.

. First Name.
Last Name.

Remove all other fields.

© Copyright 2002-2005 Epocware, Paragon GmbH
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- WyviData F Add
_— field

Les Tables Teld

ID Number (integer) Remove
FirstName Text {50) field

J LastName Text (50) Chal_Ige
X EmailAddress Text (50) field
ﬂ OK

Then press the OK button to finish creation of the table. The next step is adding new records to the table.

AW yDats el
tahle

EfzTables New

T MailingList | table
Delete

b4 tahle
- Close
Il datahase

3.2.2. Field properties.

Select the Field properties command from the Table menu to set special (additional) field properties.
The Field properties dialog will appear.

.| WExar ETr— - -
I::;? J Properties 1 “I Lookup 1 r -
Restal Field| » Type

ﬂ 22:::: Special . o _

ﬂ - E_ Close

Select a field in the Field choice list, and then you can set a special ability for this field in the Special
choice list. By default it’s None. You can also choose Lookup and Formula.

Lookup

The field with Lookup ability will be presented in the record as a choice list. You will be able to choose
its value from a pre-build set of values. Go to the Lookup pane of the Field properties dialog to define
these values.
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% XA iRTODELLIES: . 177 Add
Type Add
T:::i | Properties 1 TLuokup 1 r Delete
Restal | Shopping: Food

ﬂ Restal | Shopping: wear !
Restal | Tax . I

ﬂ Taxi Car: repair E Slose

Formula

The field with Formula ability is not entered directly, but calculated from the others record values. Go to

the Formula pane of the Field properties dialog to define the formula. Use the Insert formula button
for quick inserting field names.

AN
Client
John j
Bob Jq
Bob Jq
John 3
John ;

=L

tif et
e |

J_J_._J'J

Properties | Formula 1 1

Insert
field
Check
formula

Close

Use the Check formula button to check your formula.

Example: You have Price, Amount and Total fields. Enter values only in Price and Amount fields. And

define Total as a formula field, where the formula is Price* Amount.

You can also rename fields and define default field values in the Field properties dialog.

3.3. Adding records to a table.
To add a record to a table, you need to open the table first: select the table and press the Open table

button.

I‘H—-h

FirstName | »
LastName »
EmailAddress »

Change
focus

New
record

Delete
record

Close
table

© Copyright 2002-2005 Epocware, Paragon GmbH
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You will see the contents of the table. The new table is empty. To add a new record, press the New
record button and enter the details of the new record. Then press the OK button.

-2 My Dataghailinglist 3
likhiewrecord
0 -
_1 FirstName » Jobn
ﬂ LastName » Swmith
J 2 EmailAddress| » jon@smitheom)
i

Cancel

The new record was added to the table:

0 John Smith john@s

rx

focus

New
record

Delete
record

Close
tahle

3.4. Views and view options.

There are two different ways for viewing the records of a table:

1. Cards view. There are two panels in this view. The left panel (Browser) shows a list of the
records. The right panel (Card) shows the fields of the current record. You can switch between
these two panels by pressing the Change focus or the Tab buttons.

0 John Smith john@s

1Bob Jones hob@jone
2 James Bond 007@y
x

I‘“—»_

Cards view.

2. List view. This view presents a grid in which each record represents a row and the fields are
shown in the columns. Multiple records can be shown simultaneously.

© Copyright 2002-2005 Epocware, Paragon GmbH
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Al MyDataghailinglist Open
ID  FirstName LastMame EmailAddress re;:l_urd
- : . ew
0 John Smith john@smith.com record
1 Bob Jones bob@jones.co.uk
2 | Bond 007@yah Delete
4 ames on yahoo.com record
- Close
bl ' table
List view.

By default the Cards view is used. To switch between the views select the Switch view command from
the View menu or use the Ctrl+Q hotkey.

3.4.1. Zoom.

Use the Zoom keys to zoom in/out the contents of a table in the both Cards and List views.

3.4.2. Title.

The Title shows the names of the current database and table. It also contains the number of records in the

table.

/{0 John Smith john@s
1Bob Jones hob@jone
2 James Bond 007@y

x

i

I‘x.
FirstName| » John
LastName m» Smith

EmailAddress » john@smith.com

Change
focus

New
record

Delete
record

Close
tahle

No title.

You can show/hide the title by selecting the Show title command from the View menu.

3.4.3. Full screen.

In the List and Cards view you can select the Full screen command from the View menu to enlarge the

working screen area.

© Copyright 2002-2005 Epocware, Paragon GmbH
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ID FirstName LastName EmailAddress

0 John Smith john@smith.com
Bob Jones boh@jones.co.uk
2 James Bond 007@yahoo.com

3.4.4. Column width.

In the List view you can change the width of the columns by selecting the Columns width command
from the View menu or use the Ctrl+W hotkey. Make the width smaller to see more columns on the
screen.

ID FirstName LastName EmailAddress re:lurd
. . . ew
0 John Smith john@smith.c... record

1 Bob Jones boh@jones.co....
Delete
ﬂ 2 James Bond 007@yahoo.c... .
- Close
] tahle

Small column width.

Make the width larger to see the entire contents of the columns. Or select the Fit to screen option to fit all
the columns into the screen.

3.4.5. Browser fields in Cards view.

In the Cards view you can configure what fields to show in the Browser window. Select the Browser
fields command from the View menu. For example, to show LastName + FirstName:

- iMyiDatagl r— 3 Show
smith John | ¢se CtricArrow keys to move fields. Show
Jones Bob | ID Hide - all

J Bond Jameq LastName Show - Hide

ﬁ FirstName Show ' all

= EmailAddress Hide

ﬂ h 0K

© Copyright 2002-2005 Epocware, Paragon GmbH 13
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3.5. Editing records.

To edit a record in the Cards view, select the record in the Browser and press the Change focus or the
Tab buttons to move the focus to the Card. Edit the record in the Card, then press the Change focus
button again to move back to the Browser.

o .d : focus
0 John Smith juhn.@ﬁ - New
1Bob Jones bob@jone FirstName|» 088 e

2 James Bond 007@y LastName » Smith Del
EmailAddress » john@smith.com elete
x| || FhenatlEss B A record
- Close
] tahle

To edit a record in the List view, select the record and press the Open record button.

3.6. Sorting records.

To sort the records in the table select the Sort by command from the Find&Sort menu or use the Ctrl+S
hotkey. In the Sort by dialog select the field to sort by and press the OK button.

S| 10 —— oK
ID FirstNa )
No sorting Asc
0 John ID
J 1 Bob FirstName More
X 2 James | LastName
ﬂ EmailAddress Cancel

The records will be sorted by the selected field:

ID *FirstName LastName EmailAddress re:lurd
. ew
1 Bob Jones bob@jones.co.... record
2 James Bond 007@vyahoo.c...
: , : Delete
ﬂ 0 John Smith john@smith.c... .
- Close
] tahle

To change the sort order from ascending to descending, select the Sort order command from the
Find&Sort menu.

© Copyright 2002-2005 Epocware, Paragon GmbH 14
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Note: The * character in the header (the first row) indicates the field that’s used for sorting.

Note: You can break the sort order by modifying existing or adding new records. To restore it select the
Refresh command from the View menu or use the Ctrl+R hotkey.

3.6.1. Indexes.

The Indexes is another way for sorting the records in a table. When you use the common Sorting,
modifying or inserting new records can break the sort order. Furthermore, using the common Sorting in
the big tables can few minutes every time when you apply sorting or open the table.

The Indexes provide the way to have always up-to-date (permanent) and fast sorting.

To create an index in a table, select the Indexes command from the Find&Sort menu or use the Ctrl+I
hotkey. In the appeared Indexes dialog you will see the list of existing indexes (there is no one yet).

& £ ndexes: = Apply
Task _ ine Jl
Cv:hel| NOINdex T Newr
eBR: M o

ﬂ SDKs s Delete
CV: No N o

ﬂ eBR: NJ o Cancel

Then press the New button to create a new index. The New index dialog will appear.

=2 NEPDEWETER L Nevsindex i es Change
e JFiEldS1Upti0n51 E Jl

CV- hel -l 5N
P Field » Priority °

eBR: Mobipock Order » Descending | 4 No

ﬂ SDKs Field| » Task ) 3 Yes Cancel

CV:Nokia OK || ‘Orger » Ascending J| 3 No
@i || 2BR: Nokia OK| | " mian = 3 No Create

Here you can select up to three fields to create index by. In the Options tab you can set how many
characters of a text field are used for indexing.

© Copyright 2002-2005 Epocware, Paragon GmbH 15
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[T | T ———————————— | change
ESE I Fields | Uptionﬂ i’w
'_ &P i Set max number of characters used ¢
BBR: MObIpockl | ¢g index fast field. By default alf § 4 No
ﬂ SDKs the characters will be used, | 3 VYes Cancel
CV: Nokia OK Index| » By default § 3 No
ﬂ eBR: Nokia OK > 10 § 3 No Create

Then press the Create button and Power Data will create the desired index and apply it:

Task Priority Done re:lurd
: ew
Cebit 2002 5 No record
CV: help b No Delete
ﬂ Colors 2.0 4 Yes T
eBR: Mobipocket support 4 No Close
ﬂ CV: 21release 3 Yes table
Later you can apply the index by selecting it in the Indexes dialog
& £00s niexes p= Apply
Task _ fine
Cebit| Noindex o New
oy el Priority (Desc) / Task (Asc) | o
ﬂ Colors | Eas Delete
eBR: M Mo
ﬂ Cv: 21 les Cancel
or directly from the Tables view:
A\ Epocivare
- u Open
i<
EfzTables New
£ Tasks tahle
# Priority (Desc) / Task (Asc) |
ﬂ Delete
- Close
] database
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3.7. Finding.

To find a record in the table that contains some text, select the Find command from the Find& Sort menu
or use the Ctrl+F hotkey. In the appeared Find dialog enter the text you want to search for and press the
OK button.

% JII'_|||J:||"_.rl""i""lJ i sl meslirof 3

ID j M E]

1 Search for| » 007]
2 Where » All columns
0

Direction » Down

ﬂ Case sensitive » No
j Match » Substring
i

RN

Then the cursor (selection) will move to the next record that contains the desired text.

ID *FirstName LastName EmailAddress r_e;urd
- ew
1 Bob Jones bob@jones.co.uk record
2 James Bond 007@yahoo.com
: : : Delete
ﬂ 0 John Smith john@smith.com record
x Close
i . ' table

Note: To find the next record that contains this text, select the Find again command from the Find&Sort
menu or use the Ctrl+G hotkey.

You can fine the search by specifying the following options:

Options Descriptions

Where Select the field where to search the text.
Direction Set the direction of the search (Up or Down).
Case sensitive If perform a case sensitive search or not.
Match Select the Substring to search for a sub string.

Select the Exact to search for an exact coincidence.
Select the Pattern to search using a pattern (use the ? character instead of any
character; use the * character instead of any sequence of characters).

3.7.1. Fast find.

The Fast find is intended for finding in huge tables (e.g. 100 000 records). The Fast find works 10-20
times faster. To perform the Fast find select the Fast find command from the Find&Sort menu.

© Copyright 2002-2005 Epocware, Paragon GmbH 17
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- \EnglisheGermansDictionary, 1793274
Word Translation

a ABHfinG

abadrly  searchfor|» zom|

ﬂ a bag of Where » Word Cancel
i

a big shoe BT TR E TR YT T

a hit gin bisschen 0K

The Fast find searches a table and finds all the records that begin with entered text in the specified field.
To perform a search the Fast find creates an index by the field. This can take few minutes at the first time,
but the next time you use the Fast find, the already created index will be used.

Then the Fast find shows the found results:

LIE |

Word Translation rer::_urd
Zoom Gummilinse; Zoomobjektiv f?:;
zoomed holte heran; zoomte .
ﬂ zooming stufenlose optische Formaténderung v

Z0Oms zoomt
- Close
] tahle

Press the Esc button to return to the original table view.

3.7.2. Bookmarks.

You can use bookmarks when navigating through a table. Select the Set bookmark command from the
Record menu (or press the Ctrl+B hotkey) to set a bookmark. Then select the Go to bookmark
command from the Record menu (or press the Ctrl+Shift+B hotkey) to return to the marked record.

You can set multiple bookmarks. The bookmarks create a queue. When you select the Go to bookmark
command, you will return to the last bookmark that you set.

3.8. Filtering records.

A Filter is a way to retrieve data (records) from a table by using criteria you specify. You can create
filters using one of the following wizards:

3.8.1. Find filter.

The Find filter retrieves the records that contain some text. To apply the Find filter select the Find filter
command from the Filters menu or use the Crtl+Shift+F hotkey. In the appeared Find filter dialog enter
the text that filtered records must contain and press the OK button.
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&

%
i

ydintagdviaingList o
ID ndifilte |
_0 Search for| » 007] .
1 Where » All columns Ik
2 | Casesensitive » No M

Match » Substring

Only the records that contain the desired text will be shown in the filtered view.

ID FirstName

record

LastName EmailAddress

2 James

New
record

Bond 007@yahoo.com

Delete
record

Close
tahle

Note: To remove the filter, press the Esc button.

You can fine the filter by specifying the following options:

Options

Descriptions

Where

Select the field where to search the text.

Case sensitive

If perform a case sensitive search or not.

Match Select the Substring to search for a sub string.
Select the Exact to search for an exact coincidence.
Select the Pattern to search using a pattern (use the ? character instead of any
character; use the * character instead of any sequence of characters).

3.8.2. Advanced filter.

You can create really complex filters with the Advanced filter. To apply the Advanced filter select the
Advanced filter command from the Filters menu or use the Crtl+Shift+A hotkey. In the appeared
Advanced filter dialog compose the criteria and press the OK button.

Example: To retrieve the records where the First Name begins with the J letter, use the following filter:
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% JI"J'J:,I" U’EJ. D SHOLA
ID° Fit  wWhere » FirstName .
0 Jo Criteria » begins with om Fields
1 Bo Malue|»Jd fo.uk
2 Ja More » iom Clear all
X > !
o [
ﬂ h | 0K

The result is:

ID FirstName LastName EmailAddress
0 John Smith john@smith.com
2 \James Bond 007@yahoo.com

Delete
record

Close
tahle

You can set several conditions combined with the logical OR and AND operations. For example:

- MiyDat _
ID Fin  Where » FirstName 5
0 Jof Criteria » begins with om Fields
1 Bo (Value »Jd o b0 1K
ﬂ 2 Ja More » And ._cum Clear all
Where » LastName i
. Criteria » does not equal (<>) e
i Value| » smiel L

The result contains the records where the First Name begins with the J letter and the Last Name does not
equal Smith:
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Hyaiatasivianing |
ID FirstName LastName EmailAddress
2 James Bond 007@yahoo.com

Delete
record

Close
tahle

(= X

3.8.3. Show/hide fields.

Use the Show/hide fields filter to hide some fields (columns) and/or change the order of columns. To
access the filter select the Show/fide fields command from the Filters menu.

= et rr— i 3 Hide
ID FirstNar ) ’ _ fidress
Use Ctri+Arrow keys to move fields. N Show
0 Bob ] Pnes.couk
ID Hide K all
1 James : fahoo.com .
EmailAddress Show T Hide
4 2 John _ Emith.com all
FirstName Show I
ﬂ LastName Show OK

The result is:

EmailAddress FirstName LastName re:lurd

. ew

boh@jones.co.uk Bob Jones eyt
007@yahoo.com James Bond

: : : Delete

e john@smith.com John Smith T

- Close

] tahle

3.8.4. SQL filter.

If you are familiar with the SQL language, you can use it for creating filters. Select the SQL filter
command from the Filters menu. Enter an SQL select query and press the OK button.
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% dipta ‘*I"-n'|-:|'||'|r|r|IF'|.--i- | oK
ID Fi| eSS
0 J{ Note: Strings must be enclosed in single quote om
1 p{ characters (Vi search condition. uk
, | _sEECT|»d -
X ) WHERE w» FirstNames'James' ORLastNames='Smith'
ORDER BY w» LastMameDESC
i Cancel
SQL syntax
Description Examples
SELECT A list of field names to show in the filtered FirstName, EmailAddress
view or the * character (means all fields). *
WHERE One or more conditions combined with the ID=0
logical OR, AND, NOT operations. Allowed FirstName<>’James’
operations are =, >, <, >= <= < >, like. String | FirstName like ‘J*> AND ID>0
must be enclosed in single quote characters.
ORDER BY | A list of field names to sort by. Use the ASC FirstName
(default) and DESC keywords to specify the FirstName DESC, EmailAddress ASC
sort order.

3.8.5 Template filters.

Using the Template filters you can create filters where the conditions are not bound to concrete values,
but the values are asked when you apply the filter.

Select the Create filter>Template filter command from the Filters menu. In the appeared Template
filter dialog define the condition, but replace the values with variable names enclosed into % characters.

- | WEppg

-mm_ 7729

Task | Hyou want value to be entered when you apply filter, e
CV:hg them replace it with varialble name enclosed into Clear all
eRr- N % characters. E.g. %:Name%: or %Count.
ﬁ SDKs V-:Fhere » Priority ! Cancel
VN Criteria » equals (=)
M Value| w wpdeityd
U e6R: N Mnra 0K
Then press the OK button and enter the name for the created template.
Now select the created template filter from the Filters>Saved menu.
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[E] File Table Record Find&Sort| Filters |Reports View Tuolsr 1723 Select
Color filters... Shift+Ctrl+C
CV: help Create filter 3
eBR: Mobipocket support
N SDKs
Priority filter | | Saved filters >
Manage filters.. Shift+Ctrl+h STND Cancel

Power Data will ask you for the variable value:

- \Eppciaregdiasks 1729
Task Priority Done
CV: help i ] 5 No
8BR:Mobipo{ 4 No
ﬂ SDKs umrlt B S— 3 Yes Cancel
CV: Nokia OK 3 No
ﬂ eBR: Nokia OK 3 No 0K

Enter it and press the OK button. The filter will applied with the value that you entered:

Task Priority Done re;urd
ew
SDKs 3 Yes record
CV: Nokia OK 3 No Delet
. elete
ﬂ eBR: Nokia OK 3 No et
Software market: parser 3 Yes
- Close
i Element b 3 No table

3.8.6 Managing filters.

You can save a filter/sorting to apply it next time when you open a table. To save the current filter select
the Save current filter command from the Filters menu.

To access the saved filters select the Saved filters item from the Filters menu. In the appeared menu pane
select a filter that you want to apply.
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[E] File Table Record Find&Sort | Filters |View Tnnlsr 3 Select
_ Find filter... Shift+Ctrl+F
bob@jones.co.uk Bob Advanced filter..  Shift+Ctrl+4
i 007@yahoo.com James Show/hide fields.. Shift+Ctrl+H
N Filter #1 Remove filter Esc
| Filter #2 Save current filter
| Manage filters.. Shift+Ctrl+M| | Saved filters » HELEL

You can also access filters from the database view. Select a table and press the Right arrow key to
expand it. When the table is expanded, the items for all saved filters are shown. Select the desired filter
and press the Open button. The table will be opened and the selected filter will be applied.

AW yDats
Open
EfmTables New
2 MaillingList | table

Wz Filter #1

ﬂ T Filter #2 LalfE
- Close
] database

3.8.7 Color filters.

The Color filters do not filter the records, that answer some condition, but highlight them with specified
text or background color.

Select the Color filters command from the Filters menu. In the appeared Color filters dialog press the
New button to create a new filter. The New color filter dialog will appear.

"= m——— 1 7“1 Change
Task IHNEICOIDTIIE! ne
CV: hel Mame w» Vitaltasks Condition
eBR:M Text » W ¢

ﬂ SDKs Background » [] Bs Cancel
CV: Now Active| » Yes 0

ﬂ eBR: N¢ Ao OK

Enter a name for the new color filter. Select the text and background colors. Then press the Condition
button and define the condition.
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&

%
i

EpDCE
Task
CV: hel|
eBR: M
SDKs
CV: Nol
eBR: N¢

TR EaT)

Where| » Priority

Criteria » is greater than (>)

rl 129
e

Bs

Change

Clear all
Cancel

OK

Press the OK button to close the Condition dialog. Then press the OK button to close the New color
filter dialog.

&

%
i

EpDEE
Task
CV: hel
eBR: M
SDKs
CUHU1

eBR: N

sl L3

B[] Vital tasks

Active |

]
phe
T

N o
e
No
no

Change

New
Delete

Close

Now press the Close button and you will see the result:

Task Priority Done re:lurd

ew

CV: help 5 No eyt
eBR: Mobipocket support 4 No

SDK 3y Delete

b4 S ES record
CV: Nokia OK 3 No

o T Close

@ ||eBR: Nokia OK 3 No table

3.9. Reports.

Power Data gives you a powerful tool for analyzing your data — Reports. Using reports you can calculate
summary of any field in a table. You can find minimum, maximum, average values of any field. You can

group all records in the table by any field and calculate the count of records in each group.

3.9.1. Group amount report.

Open a table you want to create a report from. Then select the Group amount command from the
Reports menu. The Group amount dialog will appear:
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=2 VEIa RN EVEN|  Createreport 3| ahonpe
Product Group by| » Product  [| l-oUNtrY
Zip Manager for T Count records » Yes E
Fax Field » Copies T

ﬂ Code Vault for The Calculate » Sum T Clear all
Zip Manager for Tk Field » LT

ﬂ Code Vault for The - D OK

Here you can select a field to group the records by (optional). Set the Count records option to Yes, if you
want to count the records.

You can also set up to three fields to calculate in each group. In the Field line select the desired filed and
in the Calculate line select the operation (Sum, Min, Max, or Avg).

Example:
We have a table that contains orders. Each order (record) has the following fields: Product, User Name,
Address, Email, Country, and Copies.

We want to create a report to see how many copies of each product were purchased. In the Create report
dialog we should select Product in the Group by line. And select Copies and Sum in the Field and
Calculate lines (see the screenshot above).

The result is the report that has three columns: Product, Copies (Sum) and Count. The Copies column
contains the number of copies for each product. The Count column contains the number of orders for each
product (one order might contain several copies).

Product Copies(Sum) Count
Code Vault for The Nokia ... 180 151
Colors for The Nokia 9210... B2 b6
ﬂ Zip Manager for The Noki... 61 b3
eBook Reacder for The Nok... 33 29
- Close
@ || Fax 20 19 report

You can sort the report by selecting the Sort by command from the Find&Sort menu.

You can export the record to a file by selecting the Import/Export> Merge in command from the Files
menu.

3.9.2. Total amount report.

Open a table you want to create a report from. Then select the Total amount command from the Reports
menu. The Total amount dialog will appear. Select the fields to show in the report and press OK. All the
number fields will be summarized and the total amount will be placed in the last record.
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%_;_:Hr”; tl=rtl m
John Smith ~ Milk 10.00 1 1000 1260 _
BobJones  Eggs (10) 15.00 3 4500 5670 a;:'iﬂ
BobJones  Milk 10.00 2 2000 2520

ﬂ John Smith  Bread 10.00 10 10000 126.00
John Smith  Eggs (10) 10.00 2 2000 2520 Close

ﬂ 55.00 18 19500 24570 report

3.9.3. Managing reports.

You can save a report to apply it next time when you open a table. To save the current report select the
Save report command from the Reports menu.

To access the saved reports select the Saved reports item from the Reports menu. In the appeared menu
pane select a report that you want to apply.

[E] File Table Record Find&Sort Filters| Reports | View Toolsl' Select
— - Create report... Shift+Ctrl+R

Closereport  Esc

Save report
ﬂ Report #1 | | Saved reports Id:

7
Manage reports... °

i 2 Cancel

You can also access reports from the database view. Select a table and press the Right arrow key to
expand it. When the table is expanded, the items for all saved reports and filters are shown. Select the
desired report and press the Open button. The table will be opened and the selected report will be applied.

3.10. Importing data.

Power Data provides functions to import records within a table. The external file formats supported by
Power Data are CSV (Comma delimited plain text) files, DBF (dBase) files and Power Date files.

To import data into a new table, select the Import/Export>Import new table command from the File
menu. Select the file to be imported in the Import table dialog.
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&

iydinta
- -m_f 0K
EfgTables _
= Mailing (= Commu.n.lcatcfr I Browse
¢ Mailing List.csv |
Show
X all files
ﬂ Cancel
Enter a name for the new table:
2 My Data OK
Tables
E=I MailingLi
ﬂ
ﬂ Cancel

If you import data from a CSV file, then the Csv format options dialog appears, where you can specify
appropriate CSV options for your file. Use the Preview button to examine the contents of the file.

Vyiata

EfzTables
E= Mailin

L il AN G LRV T YN N

Text qualifier| » Double quote

I‘m

Label separator » Comma
rxh

Field names in first row » Yes

|
|

Change

Encoding
Preview

0K

Note: Set the Field names in first row option to Yes if the first row in the CSV file contains the field

names.

Note: If your CSV file is not in the Western European (Windows) encoding, then press the Encoding
button and choose the correct encoding.

In the next Choose fields to import dialog you can select which fields you want to import. By default all

the fields are imported. To change this select a field and press the Import/Do not import button.
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-2 WMiyDats
ER Tabled :
al'\ﬂ:i D Do not import
FirstName Text (50)
J LastName Text {50)
X Email Address Text (60)
i

Change

Import
Preview

OK

To change name and/or type of an imported field, select the field and press the Change button. Then

press the OK button to finish the importing.

3.10.1. Merge in.

To import data into an existing table, either highlight the table name or open the table. Select the

Import/Export> Merge in command from the Files menu. The subsequent process is very similar to
importing a new table. The difference is that instead of the Choose fields to import dialog, the Set fields
mapping dialog will be presented, where you need to establish the mapping between the source and

target fields.
L e vallE
Q 7L Change
=
ahzl D ID I
' FirstName FirstName
J LastName LastName
ﬂ EmailAddress Email Address
ﬂ 0K

3.11. Exporting data.

To export records from a table, open the table first. Then select the Import/Export>Export table as

command from the Files menu and select the export format.

E File | Table Record Find&Sort Filters View Tools r' 4 Seleet
Open database.. Ctrl+0 _ _ Country
New database.. atjes Fassin GmbH ... DE
Close database Shift+Ctrl+E  fAntonio Lo Porto IT
More —_—— AT
ﬂ import/Export | Import new table..| | E
_ mport/Expor Merge in table... -
||, Recent Exporttableas M| ID ance!
Select a file name for the export file in the Export table to dialog.
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- | WD atap r==t==t=== »
ID FirstN4 . =I5 0K
0 John =7 Communicator b omse
1 Bob =

J 2 James 4 Mailing List.csv

X 5P My Data

ﬂ Cancel

Then the Csv format options dialog appears if you selected the CSV export format. See the previous
topic for more information about the CSV options.

After this the table will be exported.
Note: If you have a filter applied to the table, then only the filtered records will be exported.

3.12. Compacting a database.

When you delete records and tables from a database, the space occupied by this data is not automatically
freed. You need to do it manually from time to time by selecting the More>Compact database
command from the File menu.

3.13. Compressing a database.

When you use a database only for viewing, you can choose to compress it. The compressed database will
be about two times smaller, but you will not be able to add/modify its contents. This option is useful for
references and dictionaries. To compress a database select the More>Compress database command
from the File menu.

To decompress a database select the More>Decompress database command from the File menu.

3.14. Preferences.
To open the Preferences dialog choose the Preferences command from the Tools menu.

Lo EER Gl aroEsl e lneil bl foronl
L r—— | Change
Task 2Iorslisy he
SDKs Open last database| » Yes
CV: Nd Open last table » No ¢
J eBR: N Apply last filter/sortingfindex » No o
X Soft.w Compact mode » Auto i
Show tips at startup » No -
i || Eleme . _lo OK

You can set the following options in the Preferences dialog:
e The Open last database option determines whether Power Data opens the last used database at
startup or not.
e The Open last table option determines whether Power Data opens the last used table when you
open a database or not.
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The Apply last filter/sorting/index option determines whether Power Data applies the last used
filter/sorting/index when you open a table or not.
The Show tips at startup option determines whether Power Data shows the tips at startup.

The Compact mode option switches between Auto/Manual/With confirmation modes of
compacting databases.

3.14.1. View preferences.
To open the View preferences dialog choose the View preferences command from the Tools menu.

- \Eppcivat

ﬂ eBR: Nokia

Task
SDKs
CV: Mokia (

Software

Element b

Sy Nralersilsss

| General |Columns |

Font| » System

Browser width » 40 %
Show field names » Yes
Show grid lines » Yes

I 124

i Done
Yes

® No

® No

B Yes

S No

Change

Cancel

OK

You can set the following options in the View preferences dialog:
The Font option determines what font is used to show your data.
The Browser width option sets the width of the Browser window in the Cards view.

The Show field names option determines whether Power Data shows field names in the Cards

view.

The Show grid lines option determines whether Power Data shows the grid lines in the List view.

The Columns tab allows you to specify the custom width and alignment for all the table columns in the

List view:
L RO RIAS
- RekE Bapreferences j— Change
Task ’ ¥ Done
SDKs |General Columnﬂ Ves
CV: Mokia [ Field| » Task ? No
ﬂ eBR: Nokia Wiflth » 30 inchars 8 No Cancel
Softwarer | Allgn » Left B Ves
ﬂ Element 5 8 No 0K
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